パスワードを忘れた? アカウント作成

ログインするとコメント表示数や表示方法をカスタマイズできるのを知っていますか?

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30
2017年9月6日のLinux記事一覧(全1件)
13401147 story
Android

Google、Android 8.0でLinuxカーネルバージョンの最低要件を設定 19

ストーリー by hylom
今までなかったのが不思議 部門より
headless曰く、

Android 8.0 Oreo(Android O)ではLinuxカーネルバージョンの最低要件が設けられる(Android Open Source ProjectXDA DevelopersBetaNews)。

これまでOEMは任意のバージョンのLinuxカーネルを使用できていたが、2017年に製品化されたSoCを使用するAndroid OデバイスはLinux 4.4以降、それ以外のSoCを使用する場合はLinux 3.18以降が必須となる。また、Android OではAndroid OSフレームワークとベンダー実装部分を分離してAndroid OSフレームワークの更新を容易にするTrebleが導入されており、Trebleを実装するために必要なカーネルの変更は、すべてのSoCで必要だ。なお、既存のAndroidデバイスをAndroid Oにアップデートする場合は、元のカーネルバージョンを使い続けることも可能となっている。

カーネルバージョンの最低要件チェックはVTSテストおよびOTAアップデート中に実行される。また、カーネルは.configサポートを有効にする必要もある。

typodupeerror

人生の大半の問題はスルー力で解決する -- スルー力研究専門家

読み込み中...