パスワードを忘れた? アカウント作成
この議論は賞味期限が切れたので、アーカイブ化されています。 新たにコメントを付けることはできません。

「Ubuntu 18.04 LTS」リリース」記事へのコメント

  • WSLに18.04が降ってきたらどこで変更すればいいんですか?

    • すでにハマった俺からアドバイスだ。やめておけ。

      • by Anonymous Coward

        それはアップグレードがハマったのか、システム設定がハマったのか、どっち?

        • アップグレードだよ。

          apt-line書き換えてfull-upgradeしたらebtablesパッケージ(そもそも使えねーってのに)が削除もアップグレードもできない状態にハマった。

          • by Anonymous Coward

            dist-upgradeでもハマったの?

            だとしたら依存関係ぐちゃぐちゃって事では

            それはそれで問題のような

            • いや、依存関係は壊れてないんだけど旧バージョンのebtables(Xenialのやつ)からアップデートしようとするとスクリプトでエラーが出てアップデートに失敗する上、削除もできんのですわ。

              tuneo@localhost:~$ sudo apt-get dist-upgrade
              [sudo] tuneo のパスワード:
              パッケージリストを読み込んでいます... 完了
              依存関係ツリーを作成しています
              状態情報を読み取っています... 完了
              アップグレードパッケージを検出しています... 完了
              以下のパッケージはアップグレードされます:
                ebtables
              アップグレード: 1 個、新規インストール: 0 個、削除: 0 個、保留: 0 個。
              80.0 kB 中 0 B のアーカイブを取得する必要があります。
              この操作後に 2,048 B のディスク容量が解放されます。
              続行しますか? [Y/n]
              (データベースを読み込んでいます ... 現在 57437 個のファイルとディレクトリがインストールされています。)
              .../ebtables_2.0.10.4-3.5ubuntu2_amd64.deb を展開する準備をしています ...
              invoke-rc.d: could not determine current runlevel
                * Error: insufficient privileges to access the ebtables rulesets.
              invoke-rc.d: initscript ebtables, action "stop" failed.
              dpkg: 警告: old ebtables package pre-removal script subprocess returned error exit status 1
              dpkg: 代わりに新規パッケージからスクリプトを実行してみます ...
              invoke-rc.d: could not determine current runlevel
                * Error: insufficient privileges to access the ebtables rulesets.
              invoke-rc.d: initscript ebtables, action "stop" failed.
              dpkg: アーカイブ /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2_amd64.deb の処理中にエラーが発生しました (--unpack):
                new ebtables package pre-removal script subprocess returned error exit status 1
              update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
              invoke-rc.d: could not determine current runlevel
              処理中にエラーが発生しました:
                /var/cache/apt/archives/ebtables_2.0.10.4-3.5ubuntu2_amd64.deb
              E: Sub-process /usr/bin/dpkg returned an error code (1)
              tuneo@localhost:~$

              親コメント
              • by Anonymous Coward

                ログから察するにrun level問題に見えるが...

                どうするのが最適解か分かりかねるが、手元に落としてきたdebファイルを用いていわゆるrunlevel2でアップグレードすれば良いんじゃね

              • by Anonymous Coward

                パッケージリストを取った上で、
                /var/lib/dpkg/info
                の下だっけか、削除時にエラー起こしているスクリプトの該当行をコメントアウトして再度試してみたら?
                本質的にNGならその先でまた止まるよ。
                Debian/Ubuntuのアップデートトラブルで矛盾を抱えていたら、俺はいつもそうやって解決している。
                パッケージリストから元に戻せるし。

              • by Anonymous Coward

                https://gist.githubusercontent.com/Zenexer/10bc12fa5c99848b4b2150184f6... [githubusercontent.com]

                このスクリプトで解決できるぞ!
                俺も同じ問題でハマってこのスクリプトを走ったら治ったよ
                詳しくはここから
                https://gist.github.com/Zenexer/10bc12fa5c99848b4b2150184f6beee5 [github.com]

未知のハックに一心不乱に取り組んだ結果、私は自然の法則を変えてしまった -- あるハッカー

処理中...